Outbound emails not going through
Incident Report for Sanity
Resolved
We have solved the issue and are implementing a better solution to avoid this in the future.
Posted 5 months ago. May 09, 2019 - 17:49 CEST
Investigating
We are currently investigating why email invites in manage or under /create are not going through.
Posted 5 months ago. May 09, 2019 - 17:35 CEST