Empty key in GROQ queries causing errors

Incident Report for Sanity

Resolved

GROQ Queries are now functioning as expected and this issue is resolved.
Posted 2 months ago. Feb 13, 2025 - 17:26 UTC

Monitoring

A fix has been implemented and rolled out fully. We continue to monitor the issue, but things should be back to normal operation now.
Posted 2 months ago. Feb 13, 2025 - 16:49 UTC

Identified

At 13:44 UTC, a change was deployed impacting GROQ queries using the "": shorthand syntax for empty keys. As a result, these queries may return an unexpected response. We have rolled back the change and are working to fully resolve the issue. This issue will not affect actual data, just the format of query results.
Posted 2 months ago. Feb 13, 2025 - 15:57 UTC
This incident affected: Datasets.